El "apagón de Internet": ¿Qué le pasará a tus dispositivos este 30 de septiembre?

Este 30 de septiembre, millones de dispositivos antiguos como computadoras, tablets, celulares o consolas de videojuegos podrían no funcionar correctamente al navegar en Internet. Muchos lo denominan como el gran apagón de Internet lo que pasará ese día.

¿Y qué rayos es el apagón de Internet?

En palabras simples es esto: los dispositivos que se conectan a Internet usan, digamos, unas credenciales (llamada certificado) para cifrar la conexión con el servidor y así estar seguros que el sitio web al que nos conectamos es quien dice ser y no otro fraudulento. ¿Para que se cifra la conexión? para asegurarse que nadie pueda interceptar y robar tus datos que van viajando (como contraseñas o números de tarjetas de crédito o débito).

Estas credenciales o certificados, los emite una organización sin fines de lucro llamada Let´s Encrypt. El problema es que su certificado IdentTrust DST Root CA X3 caducará este 30 de septiembre. Después de esto, los equipos, dispositivos y clientes web, como los exploradores, ya no confiarán en los certificados emitidos por esta entidad de certificación y aparecerá un error al querer ver un sitio web que ya no use ese certificado.

Como dice Tech Crunch, la mayoría de dispositivos conectados a Internet, no tendrán problemas, pero los más antiguos si.

¿Qué aparatos no podrán acceder a Internet?

Los dispositivos que probablemente se vean afectados por la caducidad del certificado son aquellos que no se actualicen regularmente, como los sistemas integrados que están diseñados para no actualizarse automáticamente o los smartphones que ejecutan versiones de software algo antiguas.

Es probable que los usuarios que ejecutan versiones anteriores de macOS 2016 y Windows XP (con Service Pack 3) se enfrenten a problemas, junto con clientes dependientes de OpenSSL 1.0.2 o anterior, y PlayStations más antiguas que no se han actualizado a firmware más reciente.

¿Y los dispositivos Android?

En teoría, los dispositivos con sistema operativo Android anterior a la versión 7.1.1 se verían afectados, pero Lets Encrypt habría trabajado ya para extender la vigencia del certificado unos tres años más. Sin embargo, los que sean versión 2.3.6 aún podrían verse sin conexión.

¿Y los dispositivos como iPhone y iPad?

Los que se verán afectados serán los que tienen un sistema operativo anterior al iOS 10. Los modelos iPhone 5 es el modelo más bajo que pueden tener iOS 10, así que los anteriores pueden tener problemas.

¿Qué hacer?

Si tienes algún dispositivo viejito, intenta actualizarlo a versiones superiores. Otro truco sería instalar o actualizar (si ya lo tienes instalado), el navegador Firefox que es el único navegador que trae sus propios certificados actualizados, por lo que podría ser la mejor opción si no quieres actualizar o si ya no lo permite el dispositivo.